Home | Manuals | FAQ | Contact Us

Steppy shift

Hi, since last week I installed Steppy and it’s a fine tool combined with other sequencers in my set up.

Cool the shift function… " * Each track can be shifted (or ‘rotated’) forward or backward by a number of steps. So if you’ve created a pattern that ‘feels’ like it has its downbeat on step 3, you can shift that pattern two steps to the left, so that the downbeat sits on step 1".

The question: after shifting the visual representation of the steps also move - since I use the shift to map Steppy with the starting point (first count) of the other sequencers (which works) it looks odd - and while programming I have to keep in mind that I push the right button. Would be nice if the visual presentation keeps the first step on the first button regardless the shifted amount…

Hope my “message” is clear and maybe my remarks isn’t possible. When possible is would be nice if the shift setting/menu shows the amount of shift with a blinking button.

Thanks a lot for your reply. Jurgen aka SONICrider.

I’m not sure I understand you correctly, but you want the sequencer to show the steps in the same position even after it has been shifted? If that was the case, how would you tell where the steps are actually located?

If the shifting was a temporary change to a pattern that might make sense, but the shifting is meant to be permanent. I believe the main concept is that this is to work with Live Tap recording mode. So if you tap in a rhythm and you’re a little behind the beat you can shift the pattern back into place.

1 Like

Hi Scott, sorry that I didn’t’t explain my issue in a clear way. Another try :slight_smile:

Since Steppy starts with an external clock, Steppy start at step 2 comparing to the master sequencer. To adjust the “delay” I used the shift function and musical it works fine. Visual it looks odd: when keying in more steps I have to active step 6 to make it trigger at step 5 from the master sequencer.

I read an article/p0st about a new firmware where the reset function and this solve the problem that Steppy “at the first pulse” goes back to step 1 and at the second pulse start… Since I use reset to maybe I have to run the firmware update?

Ik hope you can follow my explanation? Thanks again for replying. Jurgen

This post is where I talked about in the above post --> Steppy 1.1 Beta

Thanks for clarifying that @SONICrider, I think I understand now.

So yes, I think the firmware update should sort out your issue so the downbeat will be synchronized between your sequencers.

Previously Steppy would reset on the next clock pulse so that’s why it would be off a step if you sent the reset on the first step.

1 Like

Hi ScottMFR,

I did the update, based on the functionality written in post Steppy 1.1 Beta where I did a reply to, I miss " * On the SEL page, you’ll see the RST LED lit up yellow if RUN mode is enabled". Maybe I boot up in the wrong way “Toggled by Holding RST (Save) on boot”, when I do this it sets the last step of the sequencer to step 15.

To keep al clear I will not reply on the other post.

The update says " * Manually pressing RST from the SEL page will now immediately reset to step one rather than waiting for the next clock pulse." --> I still see the step were the sequencer stopped flashing.

The way I work: I have several sequencers running and the TipTop Trigger Rito sends a reset to all of them.

Hope you can help :slight_smile:. Thanks again. Jurgen

Hi Jungen,

I think in your case you do not want RUN mode enabled. Run mode means that the sequencer will only advance while it receives a high gate to the RESET input.

I feel like a very simple video with a very slow clock and some desciption of the patch would help here, emailed to support@intellijel.com.

1 Like