This update addresses an issue with repeated notes note being recognized in some cases.

Download links:

1 Like

@kamil, both links 404s for me. ¯(°_o)/¯

Here are the links I think @kamil intended for us to have:

1 Like

Fixed now!

1 Like

I just installed this firmware on my MIDI 1U and now the config app won’t recognize it :frowning:

Must be for another reason, check your USB connections etc. The only thing changed in this update was a bit of code in the mono voice allocator so it should have no effect on communication with the app.

I actually had the same problem with, which I installed right before this one. Prior to that, the config app was working fine with the same connections, same cable, etc.

Could it be something that changed going from 1.0.x.x (don’t remember exactly which it was before) to

Anything else you’d recommend trying? I rebooted the computer, cycled the power on the eurorack…

EDIT: ok… tried starting the config app with the USB unplugged, plugged it in, refreshed the devices and now it seems to work ok! After that, restarted the app with USB plugged in and it connected just fine. Weird! Glad it’s working ok again :slight_smile:


Problem solved here! Thank you so much!


So my CVx arrived today and I got it all hooked up and have been jamming with it for the first time tonight and I think I’ve noticed a change in behavior in this new firmware.

When I hit stop on the midi sequencer that is going into the MIDI 1U, all the pitch CVs cut to 0v (middle C) from whatever note they were on. I am pretty sure it didn’t behave this way before and my uMIDI 1U, which I still use for one voice, doesn’t do this either.

What MIDI sequencer are you using? Does it send the “all notes off” message when stop is hit? Because that causes all the pitches to reset to 0V.

It’s an OP-Z. I’ve been using it with the MIDI 1U in this configuration for months tho and this hasn’t been a problem until now.

That was changed in, prior to that the pitch would reset to the extreme negative value when voices were cleared (this was a bug)

I don’t see any ‘all notes off’ message when looking at everything coming out of the OP-Z on https://www.midimonitor.com/

For me, the desirable behavior is that the notes that are playing when stop gets hit can continue ringing out on the note they are playing instead of jumping to 0v. I don’t know what firmware I was using prior, but the notes wouldn’t jump when I stopped the sequencer before. Is it possible to make this an option?

Can you send me the save file from MIDI Monitor that demonstrates the behaviour? It might be the notes are being cleared somewhere they shouldn’t be.

Here’s what I see when I start the sequencer, play one measure and hit stop.

That only seems to be showing note messages, can you enable everything in the Settings? Or if you’re on a Mac, this is a good tool: snoize: MIDI Monitor

yea… will use snoize. also, just reproduced the same behavior using Ableton Live.

edit: ok yea, I see in snoize that when the stop button is hit, ‘all notes off’ gets sent on all 16 channels:

So Ableton also sends an ‘all notes off’. Anyhow, I understand that it might be correct to reset pitch to 0v when that message is received, but it is also cool to be able to stop and start sequencers in a performative way without losing the notes. I can’t really imagine a time where I’d want everything to jump to 0v. :thinking:

Yeah thinking about it more it should probably just turn off the gates but leave the pitch alone. The MIDI spec says it should “turn off all oscillators”

1 Like

haha i am relieved to hear you say that :slight_smile:

cutting the gates when the sequencer stops totally makes sense.