I’ve made an issue for this in our issue tracker so it should be fixed in the next firmware release. Thanks for the report!


Ok I’ve got another firmware update coming, should be posted tomorrow

1 Like

To add to the requests, I’d love to see a complete array of compound clock note divisions (1/3, 1/6/, 1/9. etc.). This is especially handy for the CVx. Maybe multiplications and dotted clocks, as well?

When not using CVx for poly stuff, it would be really cool to config with those clocks on tap.

May be possible but it would be more complicated. All the clock dividers are computed at all times in order to stay synced with measures (which MIDI doesn’t transmit) based on the start message. So currently we just have a fixed set based on the divisions available for the div button, so that when you switch between them they are always in sync. I suppose we could create a “pool” of clock dividers that are assigned arbitrary divisions based on what’s configured in the app, just haven’t got down to that point yet.

Okay I thought about this some more and I realized there’s a good way to retain the sync and also maintain the current performance. If we just keep a global count of number of clock ticks since the start then we can use that to set the phase / count of any clock divider when switching divisions without incurring any modulo operations. I’ll put this in our bug tracker and line it up for a future firmware :slight_smile:


Nice one, kamil! is now available:


Ive been switching up my DAWs recently. I have found the Bitwig>Umidi 1u>Metropolis setup works flawlessly.
I have been forced to go back to Ableton however because my Lauchpad has issues in Bitwig.
With Ableton Metropolis never seems to start flawlessly like it did with Bitwig. The first beat of my drum loops hit and I notice that Metropolis is on hitting the second step. Not sure why Metropolis is a beat ahead.
I will do this update in the hope that this will fix it.

Any idea why it’s behaving like this? Why only in Ableton? It works fine in Bitwig and Standalone Maschine.

If after the update you are still having issues it would be helpful if you can capture a MIDI stream from Ableton vs. one from Bitwig so I can compare the differences in what you’re seeing. If you’re on a Mac then snoize: MIDI Monitor is a good tool for this purpose.

You might want to check your rST settings in Metropolis and your SYNC settings in Ableton. Have you tried Reset Run mode?

I use it in reset run mode as I use the gate output to start it. I tested it using the run output too and it was the same. Its weird. Its was doing this consistently in ableton yesterday but fine in Bitwig. today I tried it in ableton and its fine. I restarted it several times too.
Not sure what was happening but Ill blame ableton as the timing is never as tight as it is in Bitwig. my Moog sub37 ableton timing is always shit too. it annoys me that the clock stops when ableton is stopped so all my midi clocked hardware stops running. It doesn’t with Bitwig. There isn’t a setting in either of them to achieve this.
If Ableton is stopped and my Prophet 6 or Rev 2 have the arpeggiators turned on they won’t play anything. Clocked LFOs stop too. This isn’t the case with Bitwig and I love that.
I wonder if ableton suffers from some kind of start up jitter. Bitwig is so much more reliable clock wise.

Anyhow it’s working today. Hitting on the correct beats. I’ll be constantly checking it now though.