Zeroscope 1U 1.3

Added: Screensaver with 60sec timeout

5 Likes

so, i updated to this firmware and the screensaver activates after 60 seconds even if there is activity at the inputs… surely this isn’t right/intended?

1 Like

It’s working as intended, since a lot of the UI is static. We’ll talk to VPME to see if it could be implemented differently.

Here’s a download link (mac) that includes v1.2 if you want to rollback:
https://intellijel.com/downloads/firmware/Intellijel%20Firmware%20Updater%20macOS%2020191122.zip

1 Like

ah i see. right on, thanks!

It would be nice if you could set the screensaver to something longer than 60 sec. - such as 5 minutes, or even 30 minutes… maybe if there was a preference in the menus. Great idea to save the display - but the workflow for analyzing a patch now means I’m clicking that encoder every minute :wink:

4 Likes

I don’t have a zero currently but was curious about if it has a specific feature. I find it hard to get analog clock sources to sync up correctly to a specific bpm for recording into a DAW, so I was wondering if there is a way to measure beats per minute using the zero scope.

There is not.

I have tried two different micro usb cables connected to my PC but nothing happens. Do I need to have the Zeroscope powered by my eurorack rig AND connect via usb to my PC in order to update the firmware? I don’t see anything in the manual about how to do this (unless I missed it somewhere). Also, the firmware updater readme says that you need to put the unit into bootloader mode… but again, I don’t see any documentation on how to do this. Thanks for the help.

The instructions are in the firmware updater app.

Thanks for the instructions. The update will not install for me, however. I installed the STM32 Bootloader and it says “successful”. But when I try to install the firmware this is the log output I get:

Deducing device DFU version from functional descriptor length
==> Error occurred during update.

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
No DFU capable USB device available

Here are my specs:
Win10 Pro 64bit

I tried re-installing the STM32 driver a couple of times as well. Power-cycled a couple of times too. I see the STM32 Bootloader in device manager (in USB Devices)

If you can shoot a video of you performing the video and send it to our support team at support@intellijel.com that would be good, we can see if we can find the problem there.

Updated to latest firmware this morning and it now “freeze” for about 10 sec before entering “screensaver”. Is this normal? should I contact support.

is there anyway to de-activate screensaver function?

You can roll back to v1.2 to disable the screensaver (link above). As we don’t build the firmware for this one, we’ll talk to VPME to sort out the issues with the screensaver.

It would be nice if you could set the screensaver to something longer than 60 sec. - such as 5 minutes, or even 30 minutes… maybe if there was a preference in the menus. Great idea to save the display - but the workflow for analyzing a patch now means I’m clicking that encoder every minute

+1 for this point - a screensaver is a fantastic idea, but 60 seconds is way too quick when you actually have a need to use the unit. I’d consider 5 minutes to be the bare minimum timeout for the scope to still be usable, and if it’s not configurable via the onboard menus, it makes a lot more sense to set it higher than that, probably 15 minutes.

After all, VPME / Intellijel were comfortable shipping the device with no screensaver whatsoever, so the assumption must be that they / you expect the screen to last many hundreds, if not thousands of hours of use, right? The risk comes about when people leave their modulars on for hours upon hours on end, sometimes looping a patch and sometimes doing literally nothing, just powered on. So in those situations, even having the screen turn off after an hour would still go a long way toward improving the screen’s lifespan.

While I do think the screensaver option is a much-needed enhancement for the unit, a forced unconfigurable 60 second timeout would drive me nuts. I will have to skip v1.3 but will keep an eye out for 1.4

2 Likes

can confirm. Driving me nuts.

Like I mentioned above, we reached out to Vlad to update the screensaver timing to something more reasonable and v1.2 is available above if it’s bothering you. Hard to put a timeline in this.