Home | Manuals | FAQ | Contact Us

Rainmaker v1.07/9 now available


#1

Version 1.07/9 is now ready: https://intellijel.com/eurorack-modules/cylonix-rainmaker/

ADDED: an additional mode, called “Random”, has been added to the
RANDOMIZE function. This selects a randomize mode at random from the other
15 modes.

CHANGED: by popular demand the word “PILE”, present on the original front
panel design, has been replaced by the word “STACK”. The functionality has
not been changed.

CORRECTION: the value 671 msec has been added to the list of GRAIN SIZE
values. This was left out in the previous version of the manual.

ADDED: an entry labelled DLY CLK/T has been added to the comb CLK SRC list.

ADDED: five new values have been added to the list of MOD A/B destinations.
Stereo Spread - Spreads the pan values of adjacent taps between left and
right.
Preset # - Sets the number of preset to load. Use this in conjuction with
the preset load trigger function.
All Tap Pitch - Sets the per-tap pitch shift applied to all taps (all taps
will have the same pitch shift value).
Grid - The GRID setting for the rhythm delay is controlled by the MOD signal.
Delay CLK DIV - The DIV setting for the rhythm delay is controlled by the
MOD signal.

CHANGED: now when you hold down the LOAD button when pressing the rotary
encoder while loading a preset, just the parameters of the active effects
(as stored in the preset) will be loaded.
This was the default behaviour before, now the default behaviour is to
load all parameters.

ADDED: Automatic Gain Control (AGC) circuits have been added to the rhythm
delay feedback, comb feedback, and overall output pathways. This prevents
runaway feedback and the resulting distortion.

IMPROVED: The interpolation used in the rhythm delay and comb modulation
LFOs has been improved, reducing clicks and artifacts when modulating the
delay lines.



#2

Killer work on this update, It’s so good!


#3

II"m trying to update the firmware for my rainmaker and the dropdown box for the version in the updaterr is only showing 1.07.
after the upload the fw version reads 1.07/9. and when i shut down and disconnect the usb and restart it reads fw v 1.07 only.
Any ideas why?


#4

1.07 is the latest version of the display firmware. /9 is the latest version of the DSP.


#5

Now 1.07/10 is up with super tight delay timing with external clocks.


#6

I updated to 1.07/10, but Rainmaker still shows 1.07/9 fw on reboot. Help?


And also, thank you for the /10 update to fix the external clocks. Being new to Rainmaker I thought there was actually something wrong with my system or that I just had some weird setting in Rainmaker. Great to know they’ll be tight as soon as I can get this new fw to load.


#7

Good news. I pinged Intellijel support when the forum briefly went down after posting this, and received a quick response from Danjel:

Turns out that there is currently a quirk with how the FPGA displays version number. So although it looks like I am still on v1.07/9, I am indeed running v1.07/10.


#8

I just received a new Rainmaker from PerfectCircuit – startup screen shows 1.07/9. How can I tell if I’ve got 1.07/9 or 1.07/10 with the wrong display as described here, if I didn’t update it myself? Is there a feature I can test-- something about the clock timing that would be easy to determine?

Sync


#9

All Rainmakers shipped to dealers have the latest firmware. I am certain this one has the correct version.


#10

Hi!
I bought my rainmaker a few weeks ago.
On the display it says v.1.07/9. I updated to .10

I’m not able to get a stable clock. Tried various sources. But it’s never stable.
Any suggestions?
THX


#11

I can’t upgrade the damn thing ! I tried on a pc on a mac but everytime I plug the usb /mini usb from the computer to the module it’s not even detected in the usb tab. Any help would be welcome (I’ve setup virtualbox 5.1.22 with the matching extension pack )


#12

Yeah it’s a bit of a process…

Have you watched this video?

If you’re connecting the usb mini and it’s not being detected it sounds like the drivers haven’t been correctly installed. You’ll need to go into devices/printers, select the USB blaster and install the correct 32/64 driver for whichever version of windows you’re running. The driver will have downloaded with the Quartus programmer.


#13

The USB blaster is not detected in the first place …

Edit : I run à Window 7 on virtual box


#14

If you click on settings in Virtual Box, then select the Ports Tab, and USB, do you see USB Blaster under the USB device filter list? If not you may have to add it for the Virtual Windows to see it.


#15

I’ll try it, but iif did not show how can I add it ?


#16

It’s the little USB symbol on the right with the plus sign.


#17

that’s what I’m trying to tell you : It dit not show in the list, I can not add it

also to be clear : the module is disconnected from my rack, when I plug the mini usb some leds lights up


#18

Oh ok, I misunderstood.

Is the USB Blaster detected by the apple side of things in “About this Mac”-“System Report”-“Hardware”-“USB”?

Have you tried another USB cable?


#19

My bad, usb cable was the issue !


#20

Hooray! Glad it was a simple solution. Occam’s Razor strikes again.

I had actually received a similar tech support e-mail recently where it turned out that the USB cable was the issue. I was wondering if it might have been the same person but apparently not!

Enjoy your Rainmaker upgrade…