Rainmaker 1.09/143

FIXED: Bug where routing was not loaded all the time from preset
FIXED: Bug on the routing page on power up
ADDED: Mod B Only Destination for Rhythm Delay Time (with range set by CLK DIV - repeats every 4 levels of CLK DIV) (Mod A can still be set to Delay Clock Div)
ADDED: Reduce MOD LEVEL amplitude by a factor of 8 when the encoder is pressed while the mod pages are displayed. This is to give more subtle modulations.
CHANGE: The preset load/save so now the last preset to be saved or loaded is loaded on power up
FIXED: Preset Loading Screen flashes to boot screen and hangs
FIXED: Randomizer on certain list based values

Download: https://intellijel.com/support/

2 Likes

I do all the process i see on this video but i end up with my screen saying ; v1.07/143
did i miss anything ?

You still need to update the display, the Rainmaker has 2 firmwares, grab the Intellijel Firmware updater and update the display to 1.09

mac: https://intellijel.com/downloads/firmware/Intellijel%20Firmware%20Updater%20macOS%2020191115.zip

win: https://intellijel.com/downloads/firmware/Intellijel_Firmware_Updater_Windows_2019-11-15.zip

1 Like

Well that wasn’t so pleasant from a Mac. Took me 3 hours, and I have used Quartus Prime and Virtual Box before at work, so wasn’t a complete newbie. Lots of troubleshooting trying to get USB working in VirtualBox (seems the VM needs to be powered down to switch on USB, makes sense I suppose). Finally I then had to manually load the altera driver (as shown) and additionally reboot the VM to get the driver working for some reason.

Worst bit was struggling to use the trackpad and mouse pointer on Virtual Box. Anyone know how to get it working better from a Mac?

Whenever the pointer was captured by the VM it was slow, laggy etc etc. Maybe there are some bootcamp drivers somewhere that would fix it…

Got there in the end despite some serious frustration, thanks for the video, without which I think it would have been impossible.

John

1 Like

You need to install the VirtualBox drivers within Windows (I think they call it guest extensions?) to get good performance of the graphics and mouse. There’s an option in the VirtualBox menu that mounts the installer as a virtual CD-ROM. I know it’s not much help to you know, but if you ever want to use VirtualBox for anything else in the future it might be useful.

It’s unfortunate there’s no easier way but there’s no Quartus for macOS and it’s the only way to update the FPGA firmware.

2 Likes

Oh thanks! That would have shaved a good hour off, was sure I’d got it working on Mac before but couldn’t remember what to do.

Going to try to do that and shelve a snapshot / vm for future use on a usb stick before I reclaim the disk space!

PS this worked like a charm, for others looking (and my own future reference!):

  • add a optical drive in the VM before powering it on (for example, add a Controller:SATA in the machine settings/storage setup then right click on it and ‘add optical drive’)
  • Start the VM and select from the virtualbox menu ‘Devices -> Insert Guest additions CD image’
  • Run the setup program in Windows from the CD
2 Likes

Hi I’ve updated to 1.43 but I can;t get the screen updated to work, I keep getting the following error message, I’m stuck on 1.07

C:\Users\chris\AppData\Local\Temp\2ofah502.0a5\dfu-util.exe -a 0 -s 0x08000000:leave -D “C:\Users\chris\AppData\Local\Temp\2ofah502.0a5\Intellijel_Firmware_Updater.firmware.rainmaker_1.09.bin” -d 0483:df11
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

==> Error occurred during update.

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Cannot open DFU device 0483:df11
No DFU capable USB device available

1 Like

Sorry it’s all done, I had the wrong Zadig configuration. All good, thanks

3 Likes

Noticed post upgrade that sometimes when whipping through the presets it will display “CCCCCCCCCC” instead of the preset name, turn the encoder to the next preset and back and the proper name appears…

Actually that happened to me yesterday too.

1 Like

We’ll check this out, thanks for the heads up.

2 Likes

After several hours of jamming on my rack
#30,31,32
Up/Dn Gliss and Sub Octave patches all stopped working suddenly.
As I increased the DRY to WET it would just be totally silent. I tried messing around with the other knobs and turning on and off the comb and delay but nothing.
#29 and #33 worked fine. I didn’t go through all the others.
Powered my rack off and back on and it started working again.

Latest FW and Display.

Weird… I’ll do a bit of tinkering and see if I can recreate it. Let us know if it happens again.

I have always wondered - when you select different preset ramps, one click just seems to adjust a single tap by like … 1 value or something. What’s that all about?

Also would there ever be the chance of extra shapes? Certainly for panning I like to something go 1L, 1R, 2L, 2R, 3L, 3R… things like that :slight_smile: Or 16L, 16R, 16L, 16R etc… it would be so cool if you could store your own user shapes!