Metropolis v1.30 Update

My Metropolis is also experiencing occasionally unresponsive buttons after the 1.30 update.

1 Like

Ok so based on some feedback from other users, it seems that the “unresponsive buttons” thing may be due to people holding down the buttons for too long. Since the buttons need to differentiate between clicks and holds, after a certain time of being held down they act as in the “hold” state and so won’t trigger the click event when released. For the people who are having trouble with button responsiveness, can you try a shorter click on the buttons?

I may just need to tweak the amount of time before a push down on the button is considered a hold instead of a click.

Thanks for the feedback. I flashed again today and buttons seem ok at the moment…curios thing …
I’m thinking a little bit that unresponsive buttons may start to happen after some time running the unit. I will report when strange behaviour occurs again. Unluckily
I can not test so much since I go for vacation tomorrow.
However I will make noise when there is something to report.

kamil, quick button pushing seems to be working. Thank you.

Great. For 1.31 I have increased the timeout so longer button presses (up to a point) will also work. Still a few things I want to tweak but should have a beta out early next week.


I’ve posted a beta of 1.31 in another thread. Please give it a try and leave feedback there:

is this fixing the reset problem?

Unfortunately not. I’ve looked into it but haven’t been able to determine a reliable fix yet. I’m going vacation this Friday afternoon so it will have to wait till I get back.

thx for the headsup. have a good vacation kamil

Hey @kamil, can you share your views on the reset problem? Is there still something in the pipeline, or is it unlikely this will be fixed soon?


Hi @Kamil, would it be possible to add an unquantized mode where the Metropolis puts out a straight unquantized CV? It would unlock a ton of possibilities with my Phonogene and Granpa, and also let me use the Metropolis with an external quantizer.

I was wondering why it’s not already there; is there a technical restriction or is it a design decision?

Anyways, will be updating the firmware to the latest version tonight (USB thingy is in the mail) and looking forward to the “run” reset mode that’ll let the metropolis play nice with my Minibrute 2’s sequencer.

Keep up the good work!

If it was there it would have to be pretty low resolution, there is a fair bit of noise on the ADC uses to read the sliders that’s eliminated by filtering and quantizing. Also the way the module software is designed it’s not straightforward to add an unquantized mode.

Ok — thanks for the info.

By the way, I got my usb thingy yesterday and updated my Metropolis to the latest version. The new « run » reset mode works perfectly with my Minibrute 2. Good work!

Oh and the 1v/octave on the aux is awesome. Love it.

Thanks for the lollipops and stickers! It’s a real nice touch!

1 Like

Hi there,

I received my USB ISP yesterday to begin the update procedure (to 1.36 now I think). When I connect the usb isp to my pc (I have tried three different windows PC) the USB ISP shows up as ‘driver unavailable’ and there is no option to update the driver. I have tried to troubleshoot, and tried different routes to update the driver from the zip file but without success. i cannot get past the first step of installing the usb isp to allow me update the firmware. I am on Windows10 pro.

Am I missing something?

For Metropolis you just need the AVR USB ISP driver.

There’s some instructions here:

If you can’t get it to work please contact

I was having the same problems reported above with Windows 10 firmware update failing. Couldn’t see a solution.

Setting compatibility mode on “Intellijel Firmware Updater.exe” to Windows 8 Iright click, properties, compatibility) then running as administrator seemed to do the trick. Phew.

1 Like

How do you tune an oscillator to the Metropolis in this update? The manual isn’t clear on the process.

Go to the tune option in the config menu, then tune your oscillator to a C / lowest note you want played by the Metropolis.

okay, so it does not calibrate to the oscillator by plugging the osc into one of the aux inputs. we need a separate tuner or via the ear, correct?

Yes, that’s right. It’s just a convenient way to reset the pitch.