Home | Manuals | FAQ | Contact Us

Metropolis v1.30 Update


#45

I should have some time to look at it this week. I have a bug fix for a quantizer bug already, so should be doing a patch release soon.


#46

I have the sluggish buttons too. It doesn’t remember the last saved state after power down either.


#47

I’m not really sure about the sluggish buttons thing, is it just the reset or other controls too? Have you tried reflashing the firmware? The units I’ve tried here have a pretty normal feeling button response.


#48

sluggish buttons: that was on several buttons, notably during config: it was very hard to walk the tree of parameters, and change a setting, because it would not detect the button clicks. As if (in my nontechnical view) the 24ppqn clock was taking up all CPU (it worked better when I turned the clock off).
Note that I have the old revision of Metropolis (and loaded the appropriate version of the firmware).

Last state not saved: same here (changed scale, and on subsequent powerup it was back to default chromatic).


#49

Hi Kamil, thanks for taking care.

I have sluggish/unresponsive behaviour at run, reset, save and load buttons. For run it makes a difference if it is internal or external clock. Internal is ok, external is poor. For the other button it makes no difference. Sometimes (10-20%) they respond well, but mainly they don’t do.

Sometimes I have to hit a button 8-10 times until there is a reaction. It behaves like the keyboard of a 30 years old long time not used synth, so my first idea was bad tact switches. I opened a ticket (3280) and discussed with Danjel. Now I realize that it seems to be something different.

My feeling is same as eewee, It is like to much CPU load…

I will flash 1.30 again tonight and give a feedback. I can also provide a video of the unwanted behaviour.


#50

Is the reset issue on the to do list as well?


#51

Sometimes it happens that the buttons just don’t respond on first click. Not sure if it’s clock input related. I’ll test it tonight.

Is it possible to go back to the old firmware?


#52

Hi
I want to buy one metropolis but when I read all your comments about bugs and issues, I will be honest that I’m not sure anymore.
Is it working with windows 10 for update? Is is easy to install new firmware? The explanations are not really clear, and the story of blue USB that we need to change socket etc. Is there someone who can reassure me? Except the Intellijel staff!!
Thank you.


#53

So it’s specifically wen using external clock, and the 24ppq version?


#54

So this is specifically when using external clock? Are you using the regular or the 24 ppq version?


#55

As I said before, for the run button it makes a difference if it is internal or external clock.
If internal clock is used the button pesponds perfect, if clock is set to external the run button response is poor. For the other buttons (reset, save, load) it makes no difference what clock is set.

I used the regular external clock C_EXT only.


#56

in my case, indeed: only when using (external) 24ppqn clock. Stop the clock, and it’s fine. Run it again, and the config menu becomes difficult to use because of the button response.


#57

@eewee @frankrrr Ok thanks, I’ll have a look today.


#58

@kamil thanks! Note that I care more about the original reset problem than the button behaviour (but that is just me, with my egoistic hat on :slight_smile:


#59

Hi Kamil, any findings or progress?


#60

Yes, so far I’ve fixed a few quantizer-related issues and also have fixed settings being loaded at startup. Hoping to tackle a few more bugs today and then have a beta available tomorrow for people to test.


#61

I haven’t been able to reproduce the run button problem here though. Even with an external clock at extremely high speeds (sequencer is a motorboat…) it still responds as normal.


#62

Hmm, then I will do more test under what conditions the run button responds bad and when ok. Maybe my unit is having any special problem.
How about the other buttons, could you reproduce unresponsive behaviour with reset, load and save?


#63

Unfortunately not. I’ve tried several units now and have no problems with button responsiveness even under a very fast external clock… definitely strange!


#64

Thanks for taking care… Then I will flash 1.30 again or do you have any other thing I can do or check?