Zeroscope USB Device Descriptor Request Failed

I got a Zeroscope with Firmware 1.3 loaded from the factory last year and I saw there was firmware upgrade (1.4a) and I’m having trouble connecting it to my Windows 10 PC. The problem occurs on multiple USB ports, computers, many different cables that work for other items with data connectivity, and in both bootloader mode and normal operation. I’ve tried the normal USB device troubleshooting for this with no success, is something wrong with the module?


You may have better luck downloading the drivers directly from Zadig. It may be that Windows is automatically installing the wrong driver so you will need to right click and uninstall driver then install the correct driver.

You can find the latest version of Zadig here:

I should also confirm that you’re powering up Zeroscope while holding down the encoder? If you continue to have difficulty please reach out to

I have attempted normal starts and with the encoder pressed with nothing working.

I tried your suggestion and a few more found in the github issues. I seem to have a hardware issue on the device itself according to How to run intaller_x64.exe using Zadig · Issue #110 · pbatard/libwdi · GitHub

I will email support and reference this thread.

1 Like

I am also having the same issue. Device descriptor issue on USB drive

Please reach out to if you haven’t already.

@ScottMFR ok. I will not do this before.