UScale ii saving/loading

Sorry peeps. This seems so obvious - but I’m not doing something right and it’s driving me crazy.

I’m simply trying to save a scale to one of the preset banks on the uScale. I hold down the save button. All the LEDS go green. I try pressing one of them. I’ve tried holding down one of them…I’ve then tried the reverse and loading in from the bank button…

The manual is spectacularly unhelpful in actual button pushing routine. Which is why I’m thinking I’m missing something really obvious. Can anybody point me in the right direction please?

Thank you.

Which version of the manual were you looking at? The 2018.09.13 version is more detailed.

Green LEDs indicate that a scale has already been saved in that slot. You should only have to do a long press to save the scale to EEPROM. I don’t have one in front of me to test, but I suspect you have to be in the bank already where you want to save the scale. So in that case you would hit SAVE, press the slot where you want to save the scale, then long press to permanently save the scale.

Short Press SAVE
Saves the current scale to one of 12 locations in the current bank. Empty locations are
non-illuminated while used locations are indicated with a green LED.Save to EEPROM (SAVE Button)

Long Press SAVE
Saves all stored scales/banks and settings to EEPROM non-volatile memory. If you do not do
this, all edits and changes to banks, scales and settings will be lost when you power down the

Thanks Scott

Not sure what version of the manual I was using…I think it was the latest one.

So I have a scale I want to save. If I do a short SAVE press (just slightly longer than adding that key to the scale) all the lights go green…so presumably all the presets are filled? What should I do next with all of them lit? Do I need to delete presets? If I try to press and hold one of the green lights it goes to a single orange light - but not the one I’ve pressed.

And then in terms of recalling that preset, what’s the order of button pushes there?