uMidi module sync problem

Hello. I just purchased a uMidi module to bring a clock signal into my modular synth from an external drum machine (Elektron Analog Rytm Mk2).

On the drum machine, I have the midi sync settings set to send a clock signal across the midi cable.

I connected a midi cable from the Midi Thru (tried Midi Out also just in case) to the uMidi. I pressed play on the drum machine. No clock blinking on the uMidi. I pressed the learn button and then started the drum machine again in hopes it would recognize it but nothing happens… it just stays in the learn mode with the blinking lights circling until i press learn again to exit.

For added measure, I connected the midi cable directly to a keyboard and hit the learn button and pressed a few keys on the keyboard. Still no response from uMidi. Learn mode just keeps circling like it’s not detecting anything yet.

thought maybe it was a bad cable but same issue with a few different cables known to work.

Something wrong with the uMidi?
Please help. Thank you.

Update… still not working.

I checked firmware which is on latest version .
I attempted to connect a beatstep pro to the uMidi via Midi cable in order to see if it would detect the clock signal from another sequencer. Still no luck.

I connected the uMidi to Ableton via USB cable and it worked fine. Was able to pick up the clock signal from Ableton. Only problem is I’m getting no response across the midi port for any gear that I’ve tried connecting to it.

I’m starting to think the midi port on the uMidi is bad.
Any thoughts before I return this unit?

Best to email for any support issues, they can provide some things to test, and figure out how to get it repaired if it needs to be.

Hi jphdigital,

I just sent a reply to your support e-mail. It does sound like the MIDI port is defective, but two things to check:

  1. Did you have USB and MIDI connected simultaneously? Sometimes this can confuse the device.
  2. Try updating the firmware anyway and see if this helps. It’s unlikely but it’s worth a shot.

Maybe also worth checking if there are any internal settings that are off?
Have you taken a peek using the Config Utility?

I don’t own this module but just a thought…µMIDI/

I can attest that my 2 uMIDI modules work flawlessly when getting clock via 5 pin DIN from Elektron Machinedrum UWmk2.
1 of mine is the 1U using the 7U 84hp case jacks. I then run the case’s THRU port to the 2nd (3U) uMIDI.
I also use it with Ableton via DIN MIDI, same setup, same flawless operation.
I do not use the USB MIDI ever.

When I first got these modules, I tested them heavily with MIDI sync to both of these sources using the 1/16th and Clock out jacks, as well as sending sequences to them and testing the pitch/gate/CC/MOD/VEL/Trig jacks.
Only issues I found have both been addressed in subsequent firmware updates.

Also, it doesn’t need to learn a channel to respond to incoming clock. It defaults to channel 1 anyway but regardless, the clock is not channel specific. It should respond to clock even when set to a channel not being transmitted at all by the master device.

Only other issue I’ve had is another company’s module’s reset jack not getting triggered by the reset out of the uMIDI but that turned out to be the fault of the other company, requiring an unreasonably long gate to trigger their reset. An envelope on the reset solves this but
I just use the uMIDI run jack instead and it works.

1 Like

Does anyone know how this issue was resolved? I just got a uMidi and am experiencing the exact same issue.

Best to reach out to

I had the same problem recently and discovered the power cable it came with was attached the wrong way round despite the red stripe being aligned. Once I turned it around everything behaved like it should.