Home | Manuals | FAQ | Contact Us

Shapeshifter Firmware version


#1

Does anyone know how to tell the firmware version of a Shapeshifter?

I’ve got a brand new one here straight from Intellijel so I know it’s fairly recent but I’ve been trying to work out what the actual Firmware version is for two days straight

It doesn’t display on power up and I’ve tried the Preset Mode “Detune and Load” button combo…nothing!

HELP!!


#2

From Manual 2.01 but also works for 2.02

This manual is for version 2.01 of the module’s firmware.
To determine the firmware version, enter the PRESET MODE (by pushing on the rotary encoder), then press the
LOAD button while holding down the DETUNE button. When this is accomplished, the LCD screen will alternate
between displaying “shapshft/ver 2.01”, and “CYLONIX/intllijel”.
Please refer to Appendix C of this manual for instructions on updating the module’s firmware.

There was a different way of checking earlier versions but I am still looking for that.
Also the four micro switches should be set correctly on the rear. As per the Shapeshifter updating video;

This is for older firmware;
This manual is for version 1.04 of the module’s firmware.
To determine the firmware version, press the QUANT., INT.SYNC., LFO (twice), CHORD MODE, and PERC. MODE
buttons, so that their (six) corresponding LEDs light up (note that you want to have both of the LFO 1 and 2 LEDs
light up). When this is accomplished, the LCD screen will alternate between displaying “shapshft/ver 1.03”, some
Japanese characters, and “CYLONIX/intllijel”. If there is no “shapshft/ver 1.03” (or other version display) then
your module has the original (ver 1.00) firmware. Note that a display of “ver 1.1” actually indicates version 1.01.


#3

Thanks Andrew - been trying that button combo but it just doesn’t work for me

First preset is “BASIC” which I think means it’s one of the newer batch

Just to confirm - the process should be

Power up unit

Press down the rotary encoder on the left of the module next to the screen

Preset LED should light Red and Preset “BASIC” will display on screen

Release the Rotary Encoder

Press down the button marked “MULTI/LOAD/CHORD TYPE” and whilst holding that button down also press and hold down the button on the right of the module marked “Chord Detune/Perc Delay”


#4

That’s correct - just as you described. I just did it on mine the exact same for version 2.02.

However having read that you hold down ‘LOAD’ then press ‘DETUNE’ I tried that - it wont work. While in PRESET mode with the red led on BOTH buttons must be pressed at the same time together. Not one after the other.

If you have a windows computer its worth running the latest firmware and follow the directions for having the micro switches set correctly.
When I didn’t set my micro switches on the back correctly and ran the firmware update it loaded okay and ran correctly but I couldn’t check the firmware. This might be the same problem you have if the firmware was loaded in the wrong memory location.
If you have a windows computer it is straight forward and the manual and video are spot on. It does take about an hour loading all the FPGA stuff but the actual upload is seconds.

Also try moving the module, temporarily, to a rack where the row doesn’t have any other digital modules on it.


#5

IT WORKED :slight_smile:

You have to press them at exactly the same time, holding one down and then the other doesn’t work - thank you!!