Shapeshifter firmware update issue

Hello everyone,
I’ve recently bought a 2nd hand shapeshifter and I’m trying to update the firmware but windows 10 doesn’t recognize the shapeshifter. I followed the video and tried two different cables with no success. The video says I should look for an usb blaster under device and prints, but nothing.

Any help?


This sounds familiar…
To reveal the device in Windows running as a “virtual machine” on Intel, I had to enable virtualization (“VMM”) in the BIOS security settings. Perhaps that matches your situation? I don’t think this step would help if your machine’s primary OS is in fact Windows.

Just wanted to make sure you had found this:

1 Like

Thanks but as you said my machine’s primary OS is Windows.

Yes, I’ve read it but the article starts from the assumption that every possible issue is with apple/virtual machine and not with windows 10. I’ve also checked and there are no mismatches between the programmer and windows, both are 64 bit

Ok well good luck. I had a really hard time using a Mac a couple months ago but eventually figured it out.

1 Like

It may still be worth trying on a VM of a fresh windows install. Shame (time-consuming) as you’re on windows already but it could give you a workaround or at least narrow things down in advance of contacting support if you go that route. Hope you get it going.

1 Like

I was about to install a vm, but then I tried to use a third cable and luckily It did the trick. Thank you anyway

Had a feeling that the cable was the issue. :smirk: Glad you got it going. :blush:

1 Like