Rubicon Problem

Hi! I’m having trouble with a Rubicon I just bought: it makes no sound. :neutral_face:

None of the outputs produces anything audible in either LFO or VCO mode. Connecting them to an oscilloscope reveals that they emit a constant voltage if anything at all, e.g. the sine output (left-most) emits roughly 1.5V (see below).

The symmetry knob appears to change the voltage from positive to negative, but otherwise has no effect. The sub osc output will output one of two constant voltages, depending on the switch setting. Changing coarse & fine knobs (and everything else) appears to do nothing.

The case I’m using is the Intellijel 7U 104HP performance case (TPS80WMAX PSU). My overall power consumption is well within the limits and I’ve tried several headers on the PSU busboard. At no point did I mix up the -12V connection.

Just in case I’m doing something obviously wrong, here are pics of the faceplate and scope:

I bought the module used, but according to the seller, it was only a few days old before they sold it. I’ve contacted them to see about any warranty, receipt, etc.

Any idea what’s wrong? Thanks in advance!

I had v. similar symptoms with my Rubicon. Turned out to be an issue with digital modules pulling a large amount of current when powered on. I was also well within the limits of my power supply, but (I’m assuming) the Rubicon was starved on startup and didn’t like it. Put most of my digital stuff on a different PSU and the Rubicon was fine.

1 Like

Thank you; that was it! I pulled some digital modules and now Rubicon sounds great. :grinning:

I had the same issue. I had just tried a new PSU and didn’t even think that could have caused it.