Rainmaker Firmware Updater Not Working -Solved

I was able to do the first part of the update. I had some trouble with the FPGA updater after I got the correct 64 bit version. Using the latest version of Windows 10 - April 2018 update.

Now, I can’t get the Intelliget Firmware updater to work. No problem finding the tiny switch on the display board, Here is what the Firmware updater says:

C:\Users\h\AppData\Local\Temp\qvm0tsd3.1os\dfu-util.exe -a 0 -s 0x08000000:leave -D “C:\Users\h\AppData\Local\Temp\qvm0tsd3.1os\Intellijel_Firmware_Updater.Firmware.rainmaker_1.07.bin” -d 0483:df11
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

==> Error occurred during update.

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Cannot open DFU device 0483:df11
No DFU capable USB device available


Any help. I used the support feature but no much help there. Paraphrase: read the FAQ and check the forum.

Thanks in advance.

1 Like

Problem solved. I had the wrong driver installed.

I would like to add that the support email service did in fact provide valuable assistance after all. Scott Riesterer guided me through all the steps necessary to get my Rainmaker up to current updates and factory presets.

1 Like

Glad I could help, mosc! Enjoy your Rainmaker…

Same problem here. Could you help us?
Here the message we got when wr tried the Firmware updater:
Cannot open DFU device 0483:df11
No DFU capable USB device available

Ok, problem solved :slight_smile:

Same here, drivers for the STM32 BOOTLOADER


Thank you so much for this usefull thread.
I had to read it twice, and then wondered : ok, so where can i find this stm32 bootloader ?? And I went searching in vain here and there on the web.
Well I was just stupid. Just launch Zadig.exe (which is enclosed in the intellijel_firmware_updater) and it spontaneously proposes this driver…
1 minute later, it was done.