Rainmaker Delay Clock

I just purchased a Rainmaker second hand (they’re hard to come by these days!) and it is not recognizing any clock signals to the delay clock. I’ve used Pam’s New Workout and the Mordax Data direct to RM. I tried several PPQNs with PNW, although my default is 4 and the Comb clock recognizes it immediately. Ruled out any other issues, updated firmware to 1.09, and it’s still not recognizing external clocks to the delay clock. Comb clock works fine, though. Have I been duped? Please help!

It’s most likely fine. Make sure you don’t have the Time parameter selected.

So make sure the button on the left is set to edit. Press the blue button under Clock - Div. Set the incoming clock division that you want with a clock connected. You should see the time and BPM values update accordingly.

In contrast if you select the blue button under Clock - Time, you’ll be ignoring the incoming clock and setting the delay time directly.

Thanks sincerely for your help. But, I understand how the module’s clock parameters work. I’ve tried everything from different patch cables to types of incoming clocks. Again, works fine with the comb clock, but not the delay clock. Major bummer.

Ah, ok then. That one caused some initial confusion for me. Indeed, bummer it seems to be something more than that in your case.

Other than that, I’m not aware of anything particularly fussy about the clock in. It has locked onto whatever clock I’ve sent it. You will probably have to contact support.

Just to rule out the obvious, you’re connecting the clock to the CLK in on the delay section not the comb section, right?

Yes, clock signals sent to delay clock input aren’t recognized.

Another simple thing to confirm, changing presets doesn’t make a difference?

If you have one of the MOD controls assigned to Rhythm Delay Time this would also deactivate the Delay CLK input.

Are you running the latest firmware?

Probably best to e-mail support@intellijel.com

Yes, issue persists across presets. Not sure what firmware. I updated the screen firmware to 1.09 without realizing what firmware the module was on when I purchased it. They’re independent, yes? The clock issue was happening before, though.

Yes, there’s separate screen and FPGA firmware. You have the latest screen firmware, the latest FPGA firmware is 143.

Any luck on solving this issue? I have the exact same problem: module not recognizing triggers sent into Left CLK jack (however, just like @brendanleespengler the comb section recognizes the incoming CLK signal.
Firmware v1.09 / 143

Nope, sent it in to Intellijel. But I was really happy with their communication and service. It was awhile back, but I want to say they fixed it for free or really cheap.

If you have an issue with the Delay clock input or Rainmaker in general, it’s probably best to reach out to support@intellijel.com

An easy way to check the Delay CLK input is to send a square wave to the input, and watch to see if the TEMPO LED changes. Just be aware that if CLOCK TIME is highlighted, this parameter will be assigned to the encoder so the CLK input will be ignored. Similarly if DELAY TIME is assigned to a MOD knob it will override the Delay CLK input.

Hi. I am new to the Rainmaker. But, it seems that I am also having an issue with the “DLY, FBK” & “DLY, OUT” meters… sometimes. I will keep up on this possibility because I would want tech support sooner than later. Why I am posting is because I have found a way to tell if these meters (at least) are functioning, or not. If you tap the red “TRIGGER” button a few times it will eventually tell you through randomizing what is operating or not. For this test I find setting the “DLY” & “CMB” meter gain to 15. I have a question. What does the trimmer knob on the, back, left side do?

The rear trimmer sets the output DC offset. This should be set in the factory and not need further adjusting.

What version of the firmware are you running? Could it be that the meters are not displaying because the Delay or Comb sections are muted or inactive? If you send a video to support@intellijel.com I can probably offer more insight.