Plonk Firmware updater error

Following instructions on

Downloaded firmware updater from

(on Nov 15, 2019)
Using Chrome
On MacOS 10.15.1

Tried to open it, got error:

As per screenshot above:
"Intellijel Firmware Updater’ cannot be opened because Apple cannot check it for malicious software.
This software needs to be updated. Contact the developer for more information.

How can update my Plonk firmware?


If you right click and select open, you should be able to bypass this warning and open it.

1 Like

Macs cannot “right click”.
There is no “open” button or other control available.

I did try to ctrl-click and cmd-click the OK button, but this did not open the application

Yeah that’s what I meant. Usually that’s able to bypass any of those security features.

You might need to adjust your security settings or use an administrator account. @kamil can vouch for the software not being malicious.

You need to right or control click on the app icon, then hold alt/option and you’ll see some of the text in the popup menu change. While holding this you should be able to click open and have it run.

1 Like

I’ve had some issues with Ctrl + Open on macOS Sierra and up. Sometimes Gatekeeper still gives me an error.

You could trying going to  > System Preferences > Security & Privacy > General and then click the lock icon. Afterwards, select ‘Allow apps downloaded from: App Store and identified developers’ to stop this from happening as much in the future. Also, you may see a button at the bottom right that says, “Open Anyways”, that you should click.

If nothing works, worst case scenario, you can temporarily disabled Gatekeeper via Terminal but it’s risky and not recommended. You should immediately re-enable it, after installing the Plonk firmware update, if you do windup having to disable it.

My main issue with the ctrl-open is that for some reason it closes the finder window. I could never figure out why that happens…

cmd-click on file in file browser (Finder) allowed updater to open.
When attempting update, received error:

OS version MacOS 10.15.1

Ahh, couple things to try:

  1. Make sure you hold the button on the back before powering on the module, the display should boot up blank. (full instructions in the updater itself)
  2. Try a different USB cable

Thanks for suggestions.
I was holding the Boot button when powering on, but trying a different USB cable solved the problem.
Update completed successfully - really appreciate the help!