Metropolix key transposition problem

I am sure this is fairly basic, but I couldn’t find a solution so I am posting here.
I have a fairly simple setup on Metropolix with TRK 1 & 2 running two 4-stage sequences. A third voice is keyboard controlled.
The issue is as follows: Although the scale is set to a root of ‘C’, the oscillators (and the output voltages) are pitched down a major 3rd (to Ab). All 3 oscillators are tuned in advance. If the second Home Screen shows a particular stage outputting a ‘C’ (with the root also set to ‘C’), the actual output is for ‘Ab’. Again, the output voltages are all off by a major 3rd, so I am fairly sure I have set a transposition somewhere, but I can’t seem to find it.
I assume that there are a small number of ways that this could have happened. I was playing around with using Control 1 to modulate pitch, but I went back and checked - I know that the setting has been zeroed out.
Could someone point me in the right direction? I would prefer not to simply initialize the settings - I am hoping to learn something here.
My Metropolix is up to date with the current firmware.
Any help would be greatly appreciated!

If there’s a tiny dot above the pitch on that stage on the home screen, the dot indicates a per-stage pitch override (there’s a sample on page 24 of the manual, by the on-page numbering). That might help narrow it down, whether that dot is present or not.

Oh, also - maybe try the tuner mode in the setup menu. Then you can confirm also that when Metropolix thinks it is outputting a C, you get a C, and not an Ab.

I tried the tuner earlier - C1 outputs the right voltage and the pitch from the oscillator is correct.

I couldn’t find the problem, so I reset the sequence hoping it would clear whatever is the issue. Now I notice that the second Home Screen indicates that my root is Eb mixolydian on that screen rather than the default C major listed on the scales menu. The lowest note output when a stage slider is all the way down is Eb, so it is definitely playing an Eb scale.
How do I reset that? I would like the scale setting to again control the tuning of both tracks.