Metropolix HOLD Gates are Skipping First Pulse of Next Stage (

I have my Metropolix for a couple weeks now and just updated the firmware. Idk this is a bug or if I am doing something wrong. I did a factory reset.

When I set my gate type to hold it skips the first pulse of the next stage. I have tried it on different steps, tracks and voices, and with an initialised patch and get the same behaviour. The slide, pitch, gate, ratchet, prob, accum an cv are in their init state for all stages (but not skip). No mod lanes, just the simplest possible patch.

So …
A 4 pulse hold followed by a 4 pulse hold only plays the first state.
A 4 pulse hold followed by a 4 pulse multi plays the first state and only the last 3 pulses of the second stage.

In both cases the total time is 8 pulses. Everything works as expected except for the 1st pulse of a any stage following a hold stage.

Or set all the stages to one pulse. Set some stages to HOLD. The following stages last 1 pulse but don’t trigger a note.

Repro steps:

Tap Setup
Init patch
Set GATE TYPE to MULTI for all steps
Set pulse count to 1 for all steps
Observed: All pulses play
Set GATE TYPE for some steps to HOLD
Observed: The stage following any of the HOLD stages is not heard
Set PULSE COUNT for any stage to 2
Observed: Only the second pulse is heard for these stages

Setting the Gate Type or Length to Hold ties it to the next step, so the Gate will not go low in between steps.

Check the Manual for a description. Page 19.

HOLD - The gate goes high at the beginning of the first pulse in the stage, and remains
high for the number of clock pulses set by that stage’s PULSE COUNT switch. Because
the gate is still high when the sequence advances to the next stage, it will be tied (or
slurred) to the note on the following stage.