Metropolix - delayed scale change via mod lane?

Hi, I’m using a Mod Lane to switch between User Scales, and the issue I’m running into is that when the Mod Lane = +1 (switching to User Scale 2), the first note of the pattern is still “stuck” in User Scale 1. This results in the first note of what should be a different chord being part of the “old” chord. I hope that makes sense.

Here are my settings:

TRACK 1

  • Stages = 7
  • Pulses = 16
  • Div = 1 (both Clock and Pulse Count)
  • Gate Length = 15%
  • all other track settings are Default

MOD LANE (Mod Dest: Scales (User)

  • Stages = 4
  • Pulses = Auto (I tested with Pulses = 4 and no effect)
  • Div = /16

This is likely user error. Any thoughts on how to have the Scale change happen so that the first note is in the “new” scale?

If I understand you correctly, I had the same problem but while switching between two different presets that used different scales. Here’s my post:

From my post: “The glitch is that when Metropolix switches between presets, it gets the first note of the preset wrong on the first pass…”

1 Like

Yes actually now that you mention it I had the same issue when trying to do this with presets (including preset chaining)

I should also say I’m on the latest firmware.

I’m trying to change root notes as well. The scale/root change is B Lydian (User Scale 1) to E Major (User Scale 2) and the first note of the sequence is the lowest position on the slider, and I have that set to the be Root (rather than C in the Setup Menu)

1 Like

Ah, yes, now I’m remembering, my issue wasn’t changing scales, it was changing the root.

1 Like

I will log a bug report and note to check it out. If it turns out to be an issue, I don’t have an ETA right now. Thanks for the heads up.

2 Likes

Understood, thanks for the update!

1 Like