Metropolix Bug? Can’t quick assign Red 1 to a pattern sequence

Hello, I believe I have a bug in my Metropolix. When trying to set up a quick pattern chain (hold select and tap the pattern) for some reason Red 1 wont form the first stage of the pattern. It’ll allow me to select it as the second stage but not the first. As far as I can tell the others work as expected.

I hadn’t used the Quick Chain feature until now (I had been using preset chaining the normal way), but I just tried it and it worked for me; I have a preset chain running right now that has Red 1 x2 then Red 2 x2.

But now that I’m looking at it and reading the manual, I sat there puzzled for a moment not understanding how to increase the number of repeats for a step. Then I figured it out: For example, if you press Red 1 and the “+” sign is activated, then you need to hit Red 1 again to increase the number of repeats. That wasn’t clear to me from reading the manual…FYI @slowwild :blush:

Page 162 is pretty clear:

  1. While continuing to hold the SETUP button, press one of the eight stage buttons to select which preset number to assign to the link.
    A new Preset Chain link is made, and the cursor moves to the next link in the chain. However, a “+” symbol remains next to the previous link’s Repeat value, indicating you can still increase the number of times the link repeats.

  2. If you want the previous link to repeat, simply press the same stage button again. Each time you press the stage button, the link’s repeat count will advance by one.

This was resolved in version, you probably need to upgrade your firmware. ( is the latest)

Yeah, I agree now, somehow 6 didn’t register with me.

Ok thanks I will update the firmware.