Metropolix 1.4.1 — USB MIDI / More Gx Modes / Randomizer / Bug Fixes / Updated Manual!

Thank you for the randomizer!


Is the Metropolix now functionally the same as a cv to MIDI convertor module? Can we use cv on the Met inputs and forward those to a soft synth, for example?

no, not exactly. The MIDI is generated by the sequencer, you can use the inputs as before to affect the sequence, and in turn change the midi output, but it does not convert CV to MIDI.

1 Like

What midi messages does the Metropolix respond to? Reading the manual, it looks just Clock, Start/Stop and some related messages.

It would be super handy to have midi-controlled mutes, along with some other modulation options (the same we have access to on CV X,Y, and Z) on Metropolix (feature request). Program Change messages to advance to the next preset in a preset chain would also be cool (concurrently running “song modes” on multiple sequencers gets complicated).

Thank you for this update! I’ve been eagerly anticipating the randomize features, and the usb midi is a delightful treat! I’m working on modding my case to have a micro-usb port out the side, to your suggestion in the live stream :smile:

Heads up, there is a new Play Order that missed the release notes, here’s the snippet from the manual.

Pedal Point
Forward: 1 2 1 3 1 4 1 5 1 6 1 7 1 8 | 1 2 1 3 1 4 1 5 1 6 1 7 1 8 etc…
Reverse: 8 7 8 6 8 5 8 4 8 3 8 2 8 1 | 8 7 8 6 8 5 8 4 8 3 8 2 8 1 etc…


I know you just released this incredible update. (well done by the way, it works flawlessly)

but I couldn’t help thinking it would be super fun if you could put external modulation from a different module into the metropolix via an aux in and pass it through to output via midi as a CC control message.

Not sure if this is how Metropolix is built as it sounds like it would need to convert the incoming CV rather than just output MIDI as it’s doing already, but just a thought.

Awesome! Now, can we get some kind of MIDI control over the scale that notes are quantized to? Ideally, some way to play MIDI notes and have Metropolix set the current scale’s notes to those that are being played :smiley: :smiley:

1 Like

Yes, this too is my dream… :heart_eyes:

I just got my expander in the mail from DHL and got it installed.

First thing I did was send some accumulator + converge over to arturia’s CS80 emulation. I really have to hand it to you guys on this one. Instant fun and it worked without effort.

You’ve made a good case for people who work ITB to just have a little pod or palette with a Metropolix for some hands on sequencing. Just so fun! Bravo and thank you!


Yes absolutely agree - some kind of midi cc input into the Metropolix to control its scale modulation would be amazing!
While we are at it I have a suggestion relating to scales and that is I’d really like an option to display the chosen notes in the scale menu as text rather than the iconic representation of a keyboard. In some situations it’s hard to see exactly which notes are active and cognitively it can be easier to think of the notes as letters rather than on a keyboard.
C Phryg Alt

1 Like

It would also be useful to have a non USB midi out, not necessarily DIN (maybe TRS?). To throw MIDI into other hardware synths, I’ll have to have a USB host do the conversion.

Ha! Arturia cs80 was the first thing I connected the Metropolix to when we were testing.


I seem to be experiencing an issue right after upgrading to 1.4.1. Every so often there will be a half second pause or hiccup during play. I am driving this as I always have without issue before using the digitakt driving Pam’s which is feeding Metropolix. It happens randomly but frequently. I can’t get it to reproduce on purpose. Nothing else changed in my system except the upgrade to 1.4.1. It was rock solid before.

If you can send more details to, that would be great, we haven’t heard or seen any issues since 1.4.1 was released.

Are you connected via USB? (even if you aren’t using it)
Clock source details (PPQN etc).
Have you tried clocking with another module? (like a square LFO).
Is it a half second? is the skip in-time with the clock? does it skip the pulse and continue? or is it knocked out of sync?
Do you have any probability enabled?
Have you tried a fresh Init Patch?

Send the info, and anything also relevant to the patch to the email above, we’ll try to recreate and figure it out.

When is the ACCUM bug likely to be fixed?

I’m not aware of any Accumulator issues, feel free to email if you found something, we’ll take a look at it.

We have already contacted you a week ago about the problem with Transpose Trigger set to Pulse not working properly.

I will review with the support team on Monday, I recall something regarding this, but do not believe we found any incorrect behaviour.

I reinstalled 1.3.5 to check, the behaviour you described with the accumulator when the stage is set to Single Gate Type and the Accum Trigger is Pulse was actually a bug. The accumulator in this combination should only increase the transpose counter on the first pulse of the stage (see details below). The bug was that it was accumulating on each clock pulse as long as the gate was high (If you had a Gate Length of 50% it would accumulate for 50% of the PULSE COUNT). The bug was fixed in 1.4.

Here’s a screenshot of the intended behaviour from the 1.3.5 manual.

I am surprised that this feature is a bug as I utilize it frequently and it was my favorite feature. We will continue to use 1.3.5.


I never noticed the issue but I am following you guys, and I’m also confused. Wes is saying it was fixed in 1.4 but @Kqs is saying they are going to keep using 1.3.5 as if it wasn’t?