Metropolis Issues

Has anyone else experienced these things? I’d love some help if you have it. Quite frustrated/bummed.

BPM not accurate
The Metropolis’ internal clock does not actually play back at accurate BPMs. It seems pretty spot on in increments of 10 (i.e. 70, 80, 90, 100, 110, 120, etc). As soon as you distance from a BPM increment of 10, the BPMs drift dramatically and become inaccurate. This is my second Metropolis, and Intellijel even sent me a new computer, but no luck with either of them. The first Metropolis I had wouldn’t clock accurately at any increment.

ROOT only changes between C and C#
The only two ROOT settings that work properly are C and C#. So when I go to D, it plays C. D# plays C#, then the cycle continues up the chromatic scale. E will play C. E# will play C#. This is also mirrored on the display readout.

I get quite a bit of hiss/noise from the Metropolis. I’m using Intellijel’s TPS80W bus board and Mean Well 90-Watt PSU. My rig will be silent, but as soon as the Metropolis is patched in, the hiss begins.

what firmware version are you using please?

Bumping because I have the same issues.
When running fwd 8 notes everything else default, no swing, my metropolis at 128 bpm is closer to 127.5 but it seems it cannot hold time. Changing the reset settings doesn’t seem to make a difference.

I am running the gate to plonks trigger and pitch to plonks pitch. Clk to trigger also yields same timing issue.

Firmware v 1.36


Bumping this one up, just posted in the forum about exactly the same issue, has this been resolved?

Sorry, this one somehow slipped through my radar. Tech support inquiries are best sent to for that reason.

BPM not accurate

That’s quite surprising. What are you measuring the clock sync against?

ROOT only changes between C and C#

I’ll copy/paste my reply to @motez because I think you’re experiencing the same thing.

That is actually correct behaviour. If I understand it correctly, what’s happening is the Root is changing the available notes, but it’s not transposing it, meaning C or C# will always be your bottom note. If you want to perform a transposition, you may have better luck using P.Pre with the Aux inputs.

It might also make sense if you look at the way Scales works. If you change the root note it rearranges the selected notes, but the keyboard itself is always fixed from C to C.


This sounds like a power/grounding issue. I’m assuming you are hearing the hiss through your speakers? How are you monitoring your system? Are you using balanced cables?