Metropolis Firmware update problem

I have a ARD Nano V3 Arduino programmer, and Win 10 dont let me install the usbtiny_windows8 drivers, but win10 is installing the Nano v3 manufacturers drivers.
And when I try intall from Intellijel Firmware Updater anyway I get libusb0.dll is missing.

What to do?

Looks like you can find more up to date USB Tiny drivers here:

Hello Thanks for link, but Windows says that the drivers that is installed is the most optimum so it refuses to install other drivers than CH340 driver. I have uninstalled arduini nano v3 via the Devicemanager, and tried again. Any Arduinio programmer should work ? So what do I do wrong?

What to do?

Hello - Same problem here.

Trying to update my Metropolis (rev012) on Windows 10 using ERFOS AVR-ISP (
Error says libusb0.dll is missing…

Please help.

How does your device manager see the AVR programmer?

Have you tried selecting different AVR Programmers in the Firmware Updater Preferences?

Tech support questions like this are best sent to

Thanks for your quick reply.
I have sent an email to your support.

I am having the same issue, did you get this resolved?

If you’re using a third party AVR programmer you will have to get the drivers from the manufacturer’s website. The drivers included with the Windows Firmware Updater are for the USB ISP.