Home | Manuals | FAQ | Contact Us

Metropolis 1.36


EDIT: 1.36 is now the official release and is downloadable for both Mac and Windows on https://intellijel.com/firmware-updates

Today we are releasing the beta of the 1.31 version of Metropolis. This is primarily a bug fix release with no major new features. Changes include:

  • More efficient quantizer with several bugfixes.
  • Buttons more responsive to longer clicks.
  • Fixed loading of last saved settings on startup.
  • Fixed tempo differing from reported BPM when in internal mode.
  • Fix PNG mode playing one extra step.

Please give this a try (and especially the changed features) and leave feedback (good or bad) in this thread. Currently the beta is available for download only for OS X users, a Windows version will be provided for the final release.

Metropolis v1.30 Update

Nice, but no Mac in the house, so no beta testing for me…


Windows version now available here:



Updates by a third party programmer.
Button behaviour certainly seems much better.

I am still having problems with the way root works.
All stages set to C0. Octave range is 1. Scale is major.
Set the stages to play C0 through to C1. Fine.
Change the root to D. The stages now go B0, D0, E0, F#0, G0,A0,B0,B0. Is this right?



Hm I think this may just be a bug in the note display code, not the actual pitch generation. I’ll check into this.


Well, I was checking the notes on a tuner in Ableton Live and they were giving me the same results.


Ok, I see the problem. I mistakenly set the quantizer to wrap notes which go out of bounds by one octave, but in this case the first B0 (which was quantized to a B-1 that the Metropolis can’t generate, so it wrapped up by an octave) should just be shifted to the closest scale degree which would be C#0. The other notes are as expected.


Ah well, it is beta and that’s what it"s for…


Here’s 1.32

For Mac users:


and for Windows users:


Should fix the quantizer underflow behaviour mentioned above.


That’s better.

Shall I post questions and info about the third party programmer here or the general forum?


Probably the general forum. I personally only have experience with the official AVR programmer and the two types of USB ISP we’ve sold, never tried any of the others.


PNG mode fixed here. Thanks!


I’m seeing a weird behavior with 1.32, where I’m occasionally seeing a 1 pulse stage trigger for 2 pulses, which is driving me crazy.

Can anyone else replicate this?


Hey Guys,

Thanks for the feedback, Kamil is on vacation for the next two weeks but he will attend to these bugs as soon as he is back.



i uploaded the 1.32 beta and it seemed at first to be a successful upload. but after a power cycle the lcd screen did not turn on upon stat up. so i tried to upload again and again the same results. soi decided to upload the 1.30 back onto it and now the module is completely unresponsive. i followed the instructions to the letter and have no idea what is happening please help!


I have the same problem…
When powered up the display is either correctly on, partially lit or completely off. In all three states everything works apart from the display.
The unit was updated from 1.31 and had ‘factory installed’ 1.30 before that. The unit is powered by a Doepfer 9U rack. All other modules in the rack work correctly.
It appears to be a power display only issue following recent update.
I wonder if it is a problem with the fuse settings on the chip?


Just a few little problems on the 1.32 beta.

Aux A is missing the P.PrE target and Aux B is missing G.LEn.
Also, if I set the Div In to 11 and above, the external sync stops working.


@Danjel, any word on getting these issues addressed? Thanks!


I’m back from vacation today so I will have a look this week. I think I have a fix for the display blanking which I will post today.


Here’s version 1.33 for Mac, which should fix the display blanking issue. Please give it a try and let me know: