Confusing behaviour - edit mode Steppy 1U

Hi all. This is likely going to be one of those “D’oh” moments for me once I get the answer, but I can’t seem to get this to work. I am a Steppy noob, btw.

An example of what I’m struggling with. Say, I want to add a ratchet to my step-sequence.

As I understand it, if I want to go from “Select” mode when I am running a sequence, I stop the sequence from running, and press and hold “Edit”. This is supposed to result in the red “Edit” light flashing, at which point I can choose which step I would like to ratchet.

The issue that I have is that while the “edit” light does indeed flash, so do the “Gate”, CLK", Delay “, and Prob”. Pressing any buttons (Other than the above mentioned ones) does not have any effect, until I again press the “edit” button. At this point the Steppy goes back to the sequence mode. Am I missing something? I’ve tried going through the ones that flash to see if anything makes sense for getting ratcheting going but no joy so far. Any suggestions gratefully received,


Hey @sprydle ,
I just tried to find a youtube video to show you how it works, and the first one that I found looks to be for an older version of the firmware where things work differently. I wonder if you watched that and it’s causing the confusion.

I suggest you read the latest version of the manual carefully, found towards the bottom of: Steppy 1U - intellijel

I’ll try to summarize it for you. There are several “layers” you need to navigate through and it is a bit confusing and takes some practice. Oh and first of all, you don’t need to stop the sequence to edit ratchets or other per-step parameters.

  1. First use the select button to chose the track and page you want to edit. Then exit select mode.
  2. Hold edit until the 4 buttons start flashing. You are now in step edit mode and you can edit 4 different parameters per step. The 4 flashing buttons let you choose the parameter to edit: gate length, ratchets, delay, and probability. The CLK÷ button edits ratchets (kinda makes sense, right?) and the others match the button labels.
  3. So press the flashing CLK÷ button to edit ratchets
  4. Press any of the step buttons to choose the step to edit. If you choose a step on the top row, you set the number of ratchets on the bottom row. The leftmost button sets no ratchets, the next button sets 2, and then 3, 4, 6, 8, 12, or random for the rightmost button. If you had chosen a step on the bottom row, you would use the top row to select the number of ratchets. (The manual has diagrams that should make this a lot clearer).

At this point it gets confusing because you can do several things:

  • edit other steps on the same row by pressing a button on that row and then changing the number of ratchets on the opposite row
  • press the the EDIT button to “back up one layer”, from where you can select any step, including steps on the other row
  • Or instead of selecting another step, press EDIT again to get back to the 4 flashing buttons and chose another parameter to edit
  • Or instead of chosing another parameter, press EDIT one last time to get back to the sequencer’s normal mode
  • At any point during this process you can press SELECT and switch pages and tracks, and then when you press SELECT again you’ll be at the same “layer” of step edit mode

When I was first learning this I kept getting lost after editing a step. If that happens just keep pressing EDIT until you get to the 4 flashing buttons, and then EDIT one more time to go back to normal mode.

Wow, didn’t expect that to get so wordy. Hope it helps!


Thanks so much Adam for putting so much effort into your response. You have made it very clear! Once I knock off work this afternoon I’ll give it a go. The Queen of Pentacles arrives this afternoon too so I will definitely be using steppy.

Thanks again for a very clear answer!