Cannot update Shapeshifter firmware from 1.04

My Shapeshifter is 1.04. I’ve attempted to update firmware following directions at

because of problems, I’ve attempted this without success on both my Win11 desktop and my Win8 laptop. In both, I correctly download the 64 bit exe file for my computers, which installs Quartum and also the usb-blaster driver, which in both says installed correctly.

At this point Shapeshifter is supposed to appear within Quartum, but does not. The instructional video anticipates this and provides steps to correct the driver, which fail on both my computers. On my Win8 computer, Control Panel>Devices and Printers exists as shown in the video, but no usb-blaster device exists in Additional Devices as shown in the video. In Win11, Control Panel>Devices and Printers does not exist. [Update: but now I found maybe equivalent in Win 11, ‘Bluetooth and Devices’, can try next attempt] Therefore in Win11 I searched device manager; nothing conataining ‘usb-blaster’ ‘altera’ ‘intellijel’ or ‘quartum’ is to be found [neither in the Win8 computer Device Mgr].

Google finds known problems with usb-blaster in Win10, though these references are years old. A workaround procedure found on the web fails for me because usb-blaster is expected to be found in Device Manager.

Suggestions? Thx

update: Got a more helpful reply from Intellijel, that upgrade should work at least through Win10 and problems are almost always due to use of hubs [won’t], bad type cables [getting one recommended., directly from them], or ‘not installing driver correctly’: this is the one seems problematic.

To have a fresh start I rolled back Win11 to a restore point before any attempts. Now - how should I correctly install the usb-blaster driver [actually, computer said installed correctly, but then driver seemed to disappear, unfindable in Device Manager or elsewhere] or upgrade once ‘installed’ driver is unfindable? Agent said a Windows dialog box should have popped up with options when plugging in Shapeshifter, not sure if so but definitely no dialog boxes appeared plugging mine into either Win8 or Win11 - maybe this means the cable was wrong kind?. Also rep says driver should be updateable through Windows update, but this showed no available discretionary updates. Rep seems to have no other suggestions? Once I try reinstall, how can I get at the driver then, to try to update or fix it? Or alternatively, how should I better install it than though the Quartum exe?

Found this:

Very different from how I did yesterday, accepting driver install as part of Quartum install package instead [said installed correctly] though this link seems to say requires F8 reboot with ‘disable driver signature verification’ to install.

Yesterday after having received the correct [unusual connector, not mini-B as they call it] usb cable from them directly, I successfully upgraded firmware from 1 to 2.04 with only minor glitches. Usb-blaster driver had to be accessed and updated within Device Mgr as its driver update isn’t available in Control panel as shown in their video, and it required 2 attempts, but basically the video worked for Win 11. Following Intellijel advice I tried to follow their video rather than the driver install links above.