Home | Manuals | FAQ | Contact Us

Rainmaker 1.09/142 Beta (Updated!)

Version 1.09/142 is now ready for Testing!

We’ll post official on the site once we’ve banged on it a bit, join us in testing it!

Please follow the standard directions for loading firmware onto the Rainmaker, you can find them at the bottom of this page.

JIC File: https://intellijel.com/downloads/firmware/beta/rainmaker_Aug2_2019.jic
Mac: https://intellijel.com/downloads/firmware/beta/Intellijel%20Firmware%20Updater.app%20Rainmaker%201.09.zip
Win: https://intellijel.com/downloads/firmware/beta/Intellijel_Firmware_Updater_Windows_rainmaker_1.09.zip

FIXED: Bug where routing was not loaded all the time from preset
FIXED: Bug on the routing page on power up
ADDED: Mod B Only Destination for Rhythm Delay Time (with range set by CLK DIV - repeats every 4 levels of CLK DIV) (Mod A can still be set to Delay Clock Div)
ADDED: Reduce MOD LEVEL amplitude by a factor of 8 when the encoder is pressed while the mod pages are displayed. This is to give more subtle modulations.
CHANGE: The preset load/save so now the last preset to be saved or loaded is loaded on power up
RESTORED: Preset Loading behaviour.
FIXED: Preset Loading Screen flashes to boot screen and hangs
FIXED: Randomizer on Stack Values


10 Likes

Loving the new mod options, and the fact that the last preset loads on start. I’ve been dying for that.

The behavior for loading a preset and pressing the encoder has changed though. Now, after selecting a preset and pressing the encoder, the screen jumps to the routing/config page. If I want to scroll to another preset, I have to click the load button again.

Is this an intentional change or a bug? I definitely prefer being able to audition presets quickly without having to select one, click back to load, select another and so on…

2 Likes

Oooooh, I haven’t gotten around to the update yet - but the last bit there about the encoder change will definitely deter me. I frequently use it to manually scan through presets, having a few extra steps added would negatively affect the ‘playability’ that I like so much.

Thanks for the feedback. I’ll pass this on to Jim from Cylonix, hopefully he can fix it quickly.

I didn’t realize it at first, but the new High/Low MOD LEVEL control toggle is for both the Delay and Comb sections. Very cool.

I’ve been having a lot of fun with modulating Delay time and playing with different groove patterns. With fast delay times the patterns really alter the timbre.

1 Like

I’m eager to try it out once the win installer becomes available.

1 Like

New 141 Beta (May23), reverts preset loading behaviour back to the original.

Download link above has been updated.

2 Likes

Windows Download Posted! (Thanks @kamil)

2 Likes

Updated firmware and am getting a consistent crash anytime the trigger button is set to preset load. Screen flashes to boot screen and hangs. Anyone else experienceing this with 1.09?

just to confirm, you also updated the FPGA to 141?

i’ll check when i’m in the office next week, Monday is a holiday up here.

Yep, bug confirmed, we’ll pass it on to Jim.

1 Like

Fixed, updated the top post with 142, you only need to update the FPGA

3 Likes